Why Apple avoid the GPL 3?

«That’s a pain because Apple insists on shipping a very old version of Emacs—apparently to avoid GPL 3—and mu4e won’t build because it thinks Emacs is too old.»